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A note about QGIS versions 
This workbook was written for QGIS version 3.16. If any screenshots in the workbook look 
different to the ones on your screen it’s probably because you’re on a different version, or 
have your toolbars positioned differently, but this is unlikely to cause any problems. Most 
QGIS versions are named after a city (e.g., 3.16 is called Hannover). The long-term release 
(LTR) version of QGIS is the most stable one, but you will also see a newer version of QGIS 
on the website – these often have more features but are not yet finalised for official long-
term release.  
 
This workbook is also available online, at: 
https://automaticknowledge.org/training/workbooks 
 
Licence: Attribution-Non Commercial 2.0 Generic (CC BY-NC 2.0) 
https://creativecommons.org/licenses/by-nc/2.0 
 

   

https://automaticknowledge.org/training/workbooks
https://creativecommons.org/licenses/by-nc/2.0
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About Automatic Knowledge 
Our philosophy is all about sharing data 
and knowledge, so that we can all be a bit 
better informed about the world. The way 
we do this is mainly through spatial data 
analysis and visualisation, and as part of 
this we offer training courses in geospatial 
software – mostly QGIS. Alasdair Rae 
(pictured) founded Automatic Knowledge 
in 2019 and also runs the training courses.  
 
Why ‘automatic knowledge’? 
The idea behind Automatic Knowledge is that we do the hard 
work of completing the journey from data to knowledge, so that 
you can then make more informed decisions. These training 
sessions will hopefully help you do that too. 
 
Other activities (e.g. free stuff) 
In addition to training, we provide a range of consultancy 
services, specialising in data, spatial analysis, the built 
environment and cartography. We also publish free and open 
datasets that you may find useful, at: 
 
automaticknowledge.co.uk/resources  
 
We’re also a ‘sustaining member’ of QGIS, which means that we 
donate money to the QGIS project on an annual basis, to help 
fund its development. By taking this course, you’re helping too. 

https://automaticknowledge.co.uk/resources
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Automatic Knowledge training sessions 
The idea behind all our training sessions, and these workbooks, 
is to help you learn new things in an enjoyable way, without 
confusing you. We want everyone who takes one of our courses 
to come away with useful new skills that they can then put into 
practice in their day-to-day work, and build on in the future. 
 
About this workbook 
Following a workbook can be a great way to learn new software 
skills, but there’s also a risk that it turns us into robots, following 
step-by-step instructions in a linear way. During the session 
we’ll go off at tangents and do some demos of useful skills – 
among other things. The emojis? I just add them in for a bit of 
colour, but they also serve a practical purpose because they 
can help us find key sections of the document quickly. 
 
Formatting 
Most font is size 14. When switching between screen and 
workbook this is easier on the eyes. The following format will be 
used in relation to files/folders, websites, QGIS options/tools, 
click actions and any text I want you to input. I’ve also added a 
‘Notes’ section on each page where you can jot things down. 
 
Files, folders and suchlike: e.g. 150_uk_places.gpkg 
Websites: e.g. www.automaticknowledge.org/training 
QGIS windows, tools, sections, options: e.g. Coordinate 
Actions - click menu item/ button: e.g. Vector > Research Tools 
Text input: e.g. "NAME" = 'Germany' 

http://www.automaticknowledge.org/training
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1. Understanding the QGIS interface 
Okay, let’s begin by starting QGIS (it may take a moment or two 
to load up). Once you do, you’ll see something like this, below.  
 

 
 
Before we have a play with all the buttons and tools, it’s useful to 
add some map data – otherwise QGIS might feel a bit sad.  
 
In the next section we’re going to add data to QGIS in the proper 
way but for now we’re going to use a little hack to add a world 
map – read on for how to do this. 
 

• In the Coordinate box at the bottom middle-ish of the QGIS 
window, delete the coordinate numbers you see, then type 
in world (all lower case) and then press Enter. As if by 
magic, a world map will appear!  

This is where any map 
data you add to QGIS will 

appear – it’s the main 
map viewing area 

Map layers 
appear here 

when you add 
them to QGIS 

The file 
Browser 

panel 
See below for 
more on this 
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Now I want you to spend some time getting used to what all the 
tools do for the next little while: let’s start by changing the map 
projection.  
 

• Click where it says EPSG:4326 in the bottom right of the 
screen. Make sure you’re on the CRS section to the left of 
the Project Properties window and then search for robinson 
in the Filter box and then select World_Robinson from 
Predefined Coordinate Reference Systems and click OK. 

 
• Now I want you to explore the world map with the Map 

Navigation Toolbar – spend a few minutes getting used to 
what tools do. If you can’t figure out what any of them do, 
just ask me. Note that if you hover over a tool, you’ll see a 
little tool tip telling you what that tool is or does.  
 

 
 

You might have noticed that you can’t really do 
anything with some of the tools just yet, so let’s 
look at the Attributes Toolbar (shown below) 
 

 
 

• Make sure you can see your full world map (using the 
Zoom Full  button) and then click on the Open Attribute 
Table  button to see the data behind the map.  
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• Click the NAME column header in the Attribute Table to sort 
from A to Z by country – click it again to reverse the sort. 
 

• Click a row number to highlight a country of your choice. If 
you pick a tiny country (e.g. Andorra) you may not see the 
selection (selected items are yellow on the map) so try not 
to pick a microstate – if you do, just zoom in to see that it is 
highlighted. Move the table if it is obscuring the map. 
 

This is just a little demonstration of the link between the map 
view and the data the lies beneath it. With vector-based GIS 
layers (like the one we’re using now) you’ll always have an 
Attribute Table as part of a layer. 
 
Top tip – click and drag to zoom 
When you’re navigating around maps, you can use the + and –  
magnifying glass buttons to zoom in by just clicking on them, but you can 
also click and drag round an area to zoom in or out.  
 

• Let’s make the main map background blue, to look like 
ocean. Go to the Project menu then Properties… and then in 
the General section change the Background color to a blue 
of your choice and then click OK. 

 

Okay, so far, so good. If you’re not used to QGIS it can be a bit 
baffling, but once you know how to navigate your way around a 
map, select things, and see the Attribute Table it’s all much 
easier. See below for how my screen now looks – hopefully yours 
looks similar. Feel free to close the Attribute Table now. 
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Time to save your work 
Now’s a good time to save your work.  
 
Do this now via Project > Save As… and make sure you save the project 
(ideally, in a new folder for this training session). This saves your work as a 
QGIS project file (with a qgz file extension). Call the file something like 
qgis_intro_p7 (then a different page number for future saves). Using 
incremental saves like this takes up very little disk space (e.g. 25KB) and 
allows you to go back to different points in the workbook quickly and easily. 

 
Okay, in the next section we’re going to add some data to QGIS 
in the way we normally would. 
 

• Start a new project in QGIS by clicking the New Project 
button now (also available via Project > New) and then go 
to the next page of the workbook. 

The Browser and Layer Styling panels →  
can be added via the View > Panels menu 

DON’T MISS THIS BIT! 
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2. Add data to QGIS, then explore it 
The little hack we used to add a world map to QGIS is all very 
well for a bit of exploring but 99% of the time we’ll probably want 
to use our own data.  
 
In this section of the training session, we’re going to add two 
datasets to QGIS, as described below.  
 

• A point file with 150 UK places in it – this has 150 UK towns 
and cities in it.  

• A UK General Election 2019 results file – this is a polygon 
layer with constituency-level data (e.g. winning party, 
second place, MP name, and so on) 

 
But before we add the data to QGIS we first need to download it. 
 

• Go to automaticknowledge.org/training/bonusdata/ and 
download the 150_uk_places.gpkg file and the 
GE2019_uk_results.gpkg file. It’s best if you put these two 
files in the same folder, ideally the one you’ve already 
created for this session – either way, just make sure you 
know where they’re saved to.  

 
These two files are in the GeoPackage file format, which has a 
.gpkg file extension. It’s a newer GIS format than the more 
common shapefile but it works just the same (and is better in 
several respects – not least of which because it’s just one file). 
This is just for info: you don’t need to worry about file formats. 

https://automaticknowledge.org/training/bonusdata/
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There are loads of ways to get data into QGIS, but the main way 
is via the Data Source Manager button – this lets you add loads 
of different kinds of data to QGIS. It may seem a bit fiddly at first. 
 

• Click the Open Data Source Manager  button to get 
started and you’ll see the Data Source Manager – just like 
the screenshot below. Read the text below to add the data. 

 

 
 
Once you’ve closed the Data Source Manager you should see a 
colour map of the 2019 UK General Election results. You’ll also see 
the name of the file in the Layers panel on the left – you can turn 
it on and off by ticking/unticking the little box beside its name. 

Read this very important bit of text 
To the left you’ll see all the different types of data that can 
be added to QGIS. We’re working with Vector data now, but 
you can add data of many types: e.g. via the Delimited 
Text option if you have a csv with x and y coordinates. 
 
Click the Browse button and then select the 
GE2019_uk_results file you just downloaded. Then click 
Open and then Add, then Close the Data Source Manager. 
The data will then appear on your screen – you should see 
a map of the UK showing the 2019 General Election results. 

 
 

You can dd data using 
the Browse button 

Towards the top left 
of the QGIS window 
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Baffled? 
If any of this is causing confusion, if you can’t download the data, or  
anything else weird is happening at this stage, just let me know and I’ll be 
happy to help. It should all be working fine, but I’m always here to help. 

 
You now know one way of getting your map data into QGIS, 
which is great. The Data Source Manager has lots of options and 
is very useful but sometimes it’s easier to just drag and drop 
your data into QGIS – that’s what I often do. Let’s try it now. 
 

• Go to the folder where you saved your 150_uk_places.gpkg 
and then drag it and drop it into the QGIS window (in case 
anyone’s not familiar with this method: click your left 
mouse button on the file, hold the left mouse button down, 
then drag the file over the QGIS window and then let go). 

 
You might find it easier to add data to QGIS using drag/drop 
most of the time. My advice would be to use the method that is 
most convenient for you. The end result is the same. 
 
If you’re adding, say, a csv file or an xlsx file, use the Data Source 
Manger, Vector option. We’re not doing this now though. 
 
Top tip – change layer order with drag and drop 
If your cities layer is under your UK election results layer, it’s easy to fix.  
You can re-arrange the order of map layers in the Layers panel on the left 
by dragging and dropping them up and down. Feel free to try either way. 
It’s very important to know this if you have lots of layers and particularly if 
you can’t see a layer you just added to the map. 

Woah! I zoomed in to the General Election results layer and it told me what constituency it 
was and the name of the MP who won the seat in 2019. A-may-zing. We’ll get to this later, 
but if you’ve not already checked this out, try zooming in and out and in again. 
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If you’ve done all this correctly 
then you’ll see something like 
the screenshot here → in your 
Layers panel.  
 
Okay, so what now?  
 

• I want you to explore the 
data in these layers. Do this by clicking a layer in the Layers 
panel and then right-click, Open Attribute Table. 
 

• Take some time to explore the data in both of these layers 
– e.g. have a look at each of the columns to see how the 
data is structured, what variables it has in it, and so on. 

 
The GE2019_uk_results file does of course have much more 
data in it and for that reason is probably more interesting. Here 
are some useful tips for exploring an Attribute Table. 
 

• Click a column header to sort the data from A-Z, and click 
it again to sort from Z-A. 

• Select rows by clicking the row numbers on the left. Click 
and drag to select multiple rows. When you do this, the 
corresponding areas will be highlighted in yellow on the 
map. This Attribute Table button  deselects all features. 

• Sort by A-Z in (e.g.) the constituency_name field and then 
click on the first cell (Aberavon). Now when you hit a letter 
(try ‘s’) on your keyboard, it will skip straight to the first ‘S’. 
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It’s always a good idea to have a play around when you’re doing 
this kind of thing. The Attribute Table isn’t in edit mode by default 
in QGIS, so you can’t break it and it’s a good way to learn. 
 

• Make sure you can see the different 
colour categories in the 
GE2019_uk_results layer (the little 
triangle to the left of the tick box 
does this) and then with the layer 
selected you can right-click and 
choose Show Feature Count. You’ll 
then get a count of how many 
areas there are of each colour – as 
shown here →.  
 

• Try turning the different 
categories on and off and you’ll 
see them disappear from the 
map. Right-click on any of the 
categories and you can see how to turn them all on or off 
all at once, or toggle them on/off.  

 
Okay, hopefully you’ve now had a good chance to explore this 
data and look at the Attribute Table. Let’s save and move on. 
 
Time to save your work 
Save your project – e.g. as qgis_intro_p12 then head  
to the next page. Remember to save your work regularly as you go through 
the workbook, just in case disaster strikes.  
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3. Styling data – make it look good 
Well, that was all very nice, wasn’t it? We added our data to 
QGIS and it was nicely styled and labelled. However, this doesn’t 
normally happen. Let me explain. 
 

• When you add a vector layer to QGIS it’s normally not 
styled – i.e. not colour coded or labelled. When you add a 
layer to QGIS it’s normally just all one colour (picked at 
random by QGIS) and not labelled. It can look ugly. 

 
• The reason the two layers we used were pre-styled is 

because I did that for you in advance by saving the style 
as part of the GeoPackage itself. This is another reason why 
I like to use the GeoPackage format rather than shapefiles. 
You can sort of do this with shapefiles, but not as efficiently. 
 

• So, now you know that you can save the layer style as part 
of the layer – that’s a good thing to know, and we can take 
a look at that later if you’re keen. 

 
Okay, it’s time to do some styling of our own. You should already 
have saved your QGIS project with the two layers in it. So, let’s 
move on. 
 

• Start a new project in QGIS by clicking the New Project 
button now (also available via Project > New) and then go 
to the next page of the workbook. 

DON’T MISS THIS BIT! 

What would happen if I didn’t start a new project? Well, if you’re working with data for the UK 
in one QGIS project and then add in data for the US (for example) the US data will most likely 
be upside down or on its side because the project you added it to uses the British National 
Grid projection. That’s why it’s best to start a new project – it prevents projection madness. 
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What we’re going to do now is move to the United States and 
map some election data for the 2020 Presidential Election, for 
the lower 48 states. Let’s get started. 
 

• Go to automaticknowledge.org/training/bonusdata/ and 
download the us-election-2020-lower-48.gpkg file and the 
us-states-48.gpkg file. It’s best if you put them in the same 
folder as before, just to keep everything neat and tidy. If 
you haven’t done this, that’s okay, but good file 
management is important in GIS projects. 
 

• Making sure that you are working from a blank, new QGIS 
project, add the two new US layers to QGIS. One layer has 
county-level election results and the other is a state 
boundary layer. I’ve pre-styled the states layer, but not the 
county one. Tick them on and off to see them both. 
 

• Now take a few moments to explore the Attribute Table for 
each layer. The states layer just has state names in it, but 
the county layer (us-election-2020-lower-48.gpkg) has 
much more information. 
 

The columns in the county file relate to the number and vote 
share (0 to 1) for the Democratic Party (dem), the Republican 
Party (gop) as well as totals, area names and area codes. 

 
When working with any data, it’s a REALLY good idea to spend 
some time exploring it, so you understand what you’ve got. 

https://automaticknowledge.org/training/bonusdata/
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There are two main ways we can style this kind of data, as 
described below (we’ll actually do some of this soon though). 
 

• Categorized – this is where you style a layer using some 
kind of categorical data in the Attribute Table. Categories 
are usually words (e.g. winning party, type of county), or 
some kind of alphanumeric (e.g. road names such as 
motorways, or area codes), but of course they could also 
be numbers (e.g. to represent land use types). 
 

• Graduated – this is where you style a layer using some kind 
of numerical value – e.g. like vote share or population 
density, and then use a colour scale to show the 
graduation between high and low values. This is known as 
a choropleth map. The ‘choro’ bit relates to area or region 
– from the Greek χῶρος – and the ‘pleth’ bit relates to 
quantity, as in ‘plethora’. Think of it as an area-value map. 
 

Our counties layer has numerical values that can be classified 
so we can make a graduated map quite easily. But for a 
categorized map all we can use right now is something like 
state name, but that would not be very interesting or useful. 
 
Hmm, so how could I make a map showing two categories – 
one where the Dems beat the GOP and another showing 
counties where the GOP beat the Dems? 
 
All will be revealed on the next page. Contain your excitement. 
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We could calculate a new variable in the Attribute Table 
showing which counties the Dems won and which ones the GOP 
won, but there’s a much easier way. 
 

• Close the Attribute Table, then double click the us-
election-2020-lower-48 layer to open the Layer Properties. 
 

• You’ll see the Symbology section on the left of the Layer 
Properties window – make sure this is selected. 
 

• First we need to change the Symbology to Categorized. 
 

 
 
Once you’ve done this, you can style the map using a category 
that already exists in the dataset, or you can create one on the 
fly. We’re going to create a new category using an expression. 
 

• Now, let’s enter a little expression into the Value field by 
clicking on the little Expression Dialog symbol in Layer 
Properties. First click the little symbol, then read on. 

 

 
 

• Now you’ll see a possibly-scary-looking Expression dialog 
window. Since this is an intro course, we won’t go too deep 
here but read on for a bit more on how to make this work. 
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• Now type the expression you see below into your 
Expression Dialog and then click OK. I’ve copied and pasted 
the text below this screenshot so you can copy/paste it in 
rather than typing it yourself, if you’d rather. 

 

 
 

CASE 

WHEN  "per_dem" > "per_gop" THEN 'D' 

WHEN  "per_gop" > "per_dem" THEN 'R' 

END 

 
• Once you’ve entered the expression, click OK and then 

click Classify towards the bottom left of Layer Properties– 
then Apply, then OK. Make sure you can see your counties 
layer! (i.e. make sure it’s not underneath your states layer). 

Read below for a translation of this text 
“In cases when the percent voting Democrat 
is greater than the percent voting Republican, 
please put a county in category D. 
 
When the percent voting Republican is 
greater than the percent voting Democrat, 
please put a county in category R.” 
 
Put simply, QGIS is creating two new 
categories from the existing numerical data, 
based on our little expression. Notice that 
“per_dem” and “per_gop” are the column 
names from the Attribute Table for the layer. 
 
 

Can I just click OK after I hit Classify? Yes. Apply will implement the classification but keep 
the Layer Properties window open, and sometimes that is useful – e.g. if you want to apply the 
change and then do something else in the Layer Properties window, such as label the layer. 
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Unless you are very lucky, QGIS will not have assigned the 
correct colours to the D and R categories. The colours are of 
course traditionally blue for the Democratic Party and red for the 
Republican Party. Let’s make this change now. 
 

• Double click the counties layer to go back into Layer 
Properties, then in Symbology you need to double click a 
small square colour patch to change a colour. You can 
change D to any blue and R to any red, but I recommend 
#0080ff for D and #df1809 for R. I want you to try this 
yourself but I will do a demo for everyone. Can’t figure it 
out? See the next page. 

 

Forgetting to click Classify can 
cause confusion, distress and 
discombobulation, so you 
should definitely click it. 

It can take a little while to get used to how the Symbology options work in QGIS, but as a 
general rule if you see a colour patch you can double click it and then change the colour in a 
variety of ways, including entering R, G, B values or entering an html colour code, as above. 
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Here’s how to change those colours.  
 

1. Double click a square colour patch. 
 

 
 

2. In the Symbol Selector window you’ll then see Fill and 
Simple Fill. If you click on Simple Fill you’ll then see that you 
can change the Fill color and Fill style, as well as line width 
(i.e. Stroke width). 

 
 

3. Once you get how it works it’s very simple, but it’s not 
always intuitive at first. I’d like you to spend some time on 
this to make sure you know how it works, where to click etc. 
Once you’re done, click OK until the new styles are applied. 
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Okay, cool, but how would I change the outline colour of all 
counties to white, 50% opacity, 0.1 thickness? To do that you’d 
click on the little drop-down menu in the Symbol section.  
 

 
 
Once you click on this you can configure the colour for the 
outline for both categories.  
 

1. Click on Configure Symbol then Simple Fill 
2. Change Stroke color to white – either via clicking the little 

drop-down triangle to the right of the colour patch  or 
by clicking on the colour patch itself  
and then changing the colour to white – you’ll see how it 
works when you do it. 

3. Then change the Stroke width to 0.1 
4. Then go back into the Stroke color and change the Opacity 

value to 50% 

 
 

5. Once you’ve made the changes, click OK and OK until 
everything is applied and you can see a nice red/blue 
county map with slim, slightly faded white outlines. 
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Task 
Now what I’d like you to do is try some of this on your own, so 
here’s a little task for you. I’d like you to change the Symbology 
of the states layer so that it has a transparent fill and a white 
border of width 0.3, and then I want you to put it on top of the 
counties layer (if it’s not already on top) so we can see the state 
lines on top of the county map. 
 
Any problems, just let me know and I can do a demo if 
necessary but I’d like to see if you can do this yourself now that 
you know what’s what. 
 
Tips 

• You can turn on the 
Layer Styling panel by 
clicking on the little 
icon in the Layers 
panel – the Layer Styling panel will then appear on the right 
(it’s just another way to access the Symbology options). 
 

• If you do this, just make sure the name of the layer you 
want to edit is listed at the top of the Layer Styling panel. If 
the layer you want to style isn’t currently selected you’ll find 
yourself styling a different layer by mistake! 

 
Time to save your work again 
Save your project now – e.g. as qgis_intro_p21. 
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Your map should now be looking a lot nicer, but without labels it 
will always look a bit empty. 
 

• Go to the /bonusdata folder, download us_cities.gpkg and 
then add it to QGIS, making sure it’s the top-most layer. 
 

• Double click on the new cities layer on the left in the Layers 
panel and then go to Labels to begin labelling.  
 

• Change from No Labels to Single Labels at the top and then 
you will see that the NAME field is automatically selected as 
the Value QGIS uses to label the layer – it recognises this 
by default. Click Apply to show the labels – but keep the 
Layer Properties window open. 
 

• Hmm, they look ugly. This is where you can 
change the options to make it look nicer – 
first try changing the font (via Text) and then 
add a Buffer. Not perfect, but a lot better. 
 

• Once again, the best way to get used to how 
this works is to have a go yourself. 
 

• See if you can change the font to white, with 
a 80% opacity black buffer, or something else that you 
think looks good. You may also want to change the colour 
of the city points as well as the placement. I’ll do a live 
demo of all the options so that you can follow along.  
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Follow along demo time  
I want to give you more of an extended insight into labelling in QGIS 
because it is so important and it can make or break  
a map. We’ll look at the following options, via Layer Properties: 
 
Text – using a nice font is super important. So is colour.  

Formatting – want to use all UPPER case, or all lower? We can do it all here. 

Buffer – this describes the ‘halo’ or ‘glow’ around the label lettering. 

Background – we can also use a background for our labels. 

Shadow – this can be a really nice effect, but you need to be careful. 

Callouts – not often needed, but can be really helpful. 

Placement – again, this can absolutely make or break a map. 

Rendering – this includes things like only seeing labels at some scales. 

 
 
If you spend some time today experimenting with Symbology 
and Label options in QGIS it will be time well spent. It can be 
pretty fiddly until you get the hang of it, but once you do you’ll 
find that you can create beautiful maps with minimal pain and 
in no time at all. 
 
 
Time to save your work again 
Save your project now – e.g. as qgis_intro_p23. 
 
We’re going to use some different data in the next section of the workbook, 
so make sure you save the project – it’s also useful if you want to come 
back to this later on. 
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4. Joining data – map that spreadsheet! 
So far we’ve done some basic things in this session, including: 
 

• Exploring the QGIS interface; 
• Adding different kinds of data to QGIS; 
• Styling layers in different ways, including labels. 

 
Now we’ll look at how to join data in QGIS. Here’s an example of 
how this typically works (we’ll do it for real on the next page). 
 

1. Let’s say you have a map layer in QGIS of all the countries 
in the world. In the Attribute Table of this layer you have a 
column with a three letter code for each country (e.g. NPL 
for Nepal, SWE for Sweden, and so on). 
 

2. You decide you want to explore, compare and map 
country populations, so you find a spreadsheet online with 
the data. The spreadsheet also has a three letter code for 
each country and these codes match the country codes 
you have in your map layer, so you’re all set. 

 
3. Now you can join the spreadsheet to your map layer (it 

could be a shapefile. GeoPackage or any other geospatial 
file format) and then once the join is done you can map 
the previously unmappable spreadsheet data! Nice. 
 

Let’s have a go at this now in a new , blank QGIS project. 
 DON’T MISS THIS BIT! 
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• Go to automaticknowledge.org/training/data, download 
the 1_world_countries.gpkg and 
4_world_bank_population_data_1960-2019.xlsx files and 
add them to QGIS. 
 

• Open the Attribute Table  of the 4_world_bank…  file and 
you’ll see the file has a Country Name column, a Country 
Code column, and population data for 1960-2019. If you Z-A 
sort a column (e.g. Y1960) by clicking its name twice you’ll 
see that the file contains data for the entire world, plus 
country groupings. This isn’t a problem though, because 
QGIS will only join data where there’s a matching country 
code in both datasets. Close the Attribute Table now. 
 

• Double-click the 1_world_countries layer and then go to 
the  Joins area to the left of the Layer Properties window. 

Start the join by clicking the little green plus  to the 
bottom left-ish of the Layer Properties window. 
 

• You’ll then see the Add Vector Join options. This can be 
confusing at first but all you’re doing is telling QGIS which 
data you want to join to the existing map layer, which 
columns (aka ‘fields’) your matching country codes are in 
– plus some other options. 
 

• Take a look at the next page and make your Add Vector 
Join settings look like mine. When they do, click OK, then OK. 

https://automaticknowledge.org/training/data/
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• Once you’ve clicked OK to create the join and then OK to 
exit Layer Properties the join will be complete – but how do 
you know it has worked? See below. 

 
• You can see the join has been successful by opening the 

Attribute Table of the layer you just joined the spreadsheet 
data to (in my case it was 1_world_countries) and then 
scrolling right to see the newly joined data. 
 

• This is what I always do once I’ve performed a join – just to 
be sure. Have a look yourself now and you should see all 
the country population data. Follow the instructions in the 
box on the next page to export the joined layer. 

2. MAKE SURE 
THE BOX IS 

TICKED  

1. THIS IS WHAT IT 
SHOULD LOOK LIKE 

*What if I forgot to delete the text in the Custom field name prefix box? Well, all that happens 
is that the text in there (which is the name of your join layer) gets added to the column headers 
for your newly joined table – it’s messy and annoying, but not a total disaster because you can 
always edit your original join (see next page) and re-export the layer. 

3. DELETE ANY TEXT 
YOU SEE HERE 
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Remember this – and do it yourself now too 
When you perform a join like this, it’s not a permanent thing. 
A join is a temporary connection between files. If we want to permanently 
save the joined layer, we can export it as a new layer in QGIS. This is done 
via a right-click on the layer name (in the Layers panel) that we joined the 
data to (i.e. 1_world_countries), not the xlsx spreadsheet it came from. 
 
So, right-click 1_world_countries, Export > Save Features As… and save the 
new layer with a sensible name in a folder via the  button towards the 
top right. Note that when you’re exporting to a new layer, the Save Vector 
Layer as… options in QGIS allow you to select which fields to include in the 
export – that is, you get the choice of which Attribute Table columns to 
include in the new layer – very useful if you only want a few of them. 
 

• I saved my layer as 1_world_countries_with_pop_data as 
a GeoPackage (the default format) and it then added to 
the map as a new layer. Make sure you’ve done this too, 
though don’t worry if your file name is different from mine. 
 

If you ever need to edit a Join, you can do this by going back to 
Layer Properties > Joins (in the original layer you did the join on) 

and clicking the little pencil  icon. This can be pretty useful! 
 

• Open the Attribute Table of the newly created layer and 
sort the Y2019 column (scroll right to find it) of your newly 
joined layer by clicking on the column header. Lots of NULL 
values? Have a look at which countries or areas these are – 
you’ll notice they are mostly small territories, for which the 
World Bank does not publish data. 
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• Let’s remove Antarctica. Right-click the new layer with the 
population data in it, then Filter… then enter this query: NOT 
"SOVEREIGNT" = 'Antarctica' and then click OK to activate it 
and Antarctica will disappear. Turn off your original world 
countries layer if you still have it on and then you should 
have a world map without Antarctica. 
 

• When you created the new layer after the Join above, it will 
most likely have appeared in a random, possibly ugly 
colour so feel free to change it to one that looks nicer – I 
always do this. 
 

• The last thing I want you to do in this section is change the 
new world map to a Graduated symbology, showing % 
population change by country between 1960 and 2019. 
Take the text below and type or paste it into the Value box 
after setting the new layer symbology to Graduated and 
don’t forget to click Classify afterwards! You should then 
have a map of % population change since 1960. 
 
("Y2019" - "Y1960") / "Y1960" * 100 

 

 

N.B. Just be aware that when you create a Graduated map in QGIS, it will, by default, put an 
equal number of areas in each category and it will use 5 classes by default. You can classify 
data in lots of different ways – and the appropriateness of this varies by dataset. I will say 
more about this during the day, but for now just be aware that this is what happens by default. 



Making Meaningful Maps, with QGIS           automaticknowledge 

29 
 

Notes 

5. Adding a base map  
The idea in the early part of this workbook was to get you up to 
speed with QGIS, as well as just becoming familiar with the QGIS 
interface – how it looks, where to find stuff. That’s why it was 
more step-by-step. As we go on, we’ll do less of that, starting 
from now, but if you need me to demo something, let me know.  
 
It’s often very useful when doing any mapping to be able to add 
a high-resolution base map (e.g. Google Maps, Bing Maps, or 
OpenStreetMap). Let’s add one of these in now. 
 

• Turn off (untick ) all layers apart from 1_world_countries 
. In the Browser panel on the left expand (via little black 

triangle ) XYZ Tiles, then double-click OpenStreetMap to 
add it to the map. It may be all squished when you do. 

 
• Change the projection to WGS 84 / Pseudo-Mercator (via 

the EPSG button in the bottom right of the QGIS window). 
This is the projection you’ll need to use to ensure any XYZ 
Tiles maps are 100% crisp and not slightly fuzzy-looking. 
Just search in the Filter box for this projection if needed.  
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• What you may need to do at this stage is move your new 
OpenStreetMap layer below your countries layer, and also 
make the Fill color of the world countries layer transparent. 
Once you do this, you should see country borders on top of 
the OpenStreetMap layer. 

 
• Take some time to pan and zoom around the map – 

including zooming right in to different parts of the world at 

a very local level. You can use the Zoom tools  to do 
this, or your mouse scroll wheel.  
 

• A nifty trick with this kind of thing is to use Inverted 
Polygons in the Symbology, set the Fill and Stroke color to 
75% opacity black and then Filter the layer so only one 
country is featured – e.g. right-click the layer, and via Filter 
enter this text to show Germany: "NAME" = 'Germany'. Don’t 
worry if you can’t figure this out – you can just ask me to 
demo it for you. 
 

The base map here provides some additional context, though 
isn’t strictly necessary now – but it can often be really useful. 
 

• Before you move on, turn off the OpenStreetMap layer, and 
just have the two world countries layer turned on – using a 
Single Symbol style on both of them, with no Filter. Change 
the projection back to World Robinson or WGS84 as well. 

  

Looking for different kinds of base maps to add to QGIS? Check out this link: 
 
https://gis.stackexchange.com/questions/20191/adding-basemaps-from-google-or-bing-
in-qgis/217670#217670  

https://gis.stackexchange.com/questions/20191/adding-basemaps-from-google-or-bing-in-qgis/217670#217670
https://gis.stackexchange.com/questions/20191/adding-basemaps-from-google-or-bing-in-qgis/217670#217670
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6. Querying data – start asking questions 
The idea behind this part of the workbook is that we start asking 
questions of our data, using queries to find the answers. 
 

Here’s an example: The World’s Cities in 2018 report from the 
United Nations identified Tokyo as the world’s largest urban 
agglomeration (they say ‘city’ but really it’s the much larger 
metro area covering most of the Kantō region), with a 
population of 37,468,000. We want to see how many countries in 
the world have a lower population than this, in map form. 
 

• Run this Filter… on your new country + population layer: 
"Y2018" < 37468000 AND NOT "SOVEREIGNT" = 'Antarctica' 
(note that the ‘AND NOT…’ bit just keeps Antarctica turned 
off). See below for my results (I’ve turned the projection 
back to World_Robinson here, as I mentioned above). 

 

 

Tokyo metro area has a 
lot of people in it! 

There are two layers in the map above. The top layer is our new country + population data, with 
the above filter applied. The other layer is the original world countries layer, underneath it. This 
layer has the NOT "SOVEREIGNT" = 'Antarctica' filter applied so that Antarctica is not 
showing. It Antarctica is showing on yours, that’s fine – but this Filter will turn it off. 
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Note that in QGIS you can use this same query structure to 
select features as well. For example, if you wanted to select all 
countries with a lower population than ‘Tokyo’ and then Export 
the selected countries to a new layer. The query is the same, but 
you’d do it via the Select Features by Expression… button (as 
shown below).  
 

 
 
How do you know how many countries are included in a Filter or 
Select operation? You’ll always see this information at the top of 
an Attribute Table window, and for a Filter you can see the 
number of features via a layer right-click > Show Feature Count. 
 
The point of this section was to demonstrate how you can use 
filters and queries to explore your data. You can try more 
yourself, or ask me any questions if you’re not sure.  
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7. Spatial analysis: a very brief look 
QGIS can display maps, as you’ve seen. You have also seen how 
you can query the data behind those maps. 
 
Let’s take a look at how to do some simple spatial analysis tasks.  
 

• First make sure nothing is selected on your map (Deselect 
Features from All Layers ) – it’s also a good idea to save 
your project now, adding the page number to the project 
file name like before. 

 
• Now make sure one countries layer is visible, and unfiltered 

(it’s okay if Antarctica is still turned off with a filter though). 
 

• Now, with one countries layer selected in the Layers panel 
on the left, use the Select Feature(s)  tool to select 
Germany – just by clicking on it. Now we’re going to do a 
quick bit of spatial analysis to find out how many countries 
border Germany. 
 

• Go to Vector > Research Tools > Select by Location… and 
then head to the next page to make sure your options 
match mine before hitting Run. 
 

What’s happening here? We’re just doing a little bit of spatial 
analysis as an introduction to the different kinds of spatial 
questions you can ask, and answer, with any GIS package. 
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• Hit Run and you’ll see that all countries bordering Germany 
are selected. Close the Select by Location window, open 
the Attribute Table for the layer and you’ll see at the top of 
the window it tells you how many features are selected – 

you can hit the Move selection to top  button to see 
them all. 

• Now deselect all features  and try this for any country 
you want. 
 

That’s the end of our very brief spatial analysis interlude – now 
it’s time to make some pretty maps!  

MAKE SURE THE BOX IS 
TICKED – IF NOT, THE 

WHOLE WORLD WIL BE 
SELECTED! 

YOU MAY HAVE USED A DIFFERENT 
COUNTRIES LAYER HERE, THAT’S FINE 

– JUST MAKE SURE IT’S THE SAME 
LAYER LISTED IN BOTH PARTS. 

We can only cover so much in one day, but if you want to explore more spatial analysis tools I 
recommend: i) the Analysis Tools in the Vector menu; ii) go to the Processing menu then 
Toolbox and search for ‘analysis’ in the Processing Toolbox search box and look at all the 
options available to you.  
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8. Using the Print Layout to make a map 
We’re going to spend some time now looking at how to create a 
nice map in the Print Layout. This is the area of QGIS where you 
design, edit and export high quality maps. The main map 
viewing window we’ve used so far is where you explore, analyse 
and investigate data – although it is also possible to export high 
quality, production-ready maps directly from the main map 
view too (though with fewer features). 
 
I want everyone to decide for themselves what map they’re 
going to make. I provide some options below but I encourage 
you to use any other data you might find interesting. This 
section is about getting to grips with how the Print Layout works 
and it often helps if you’re mapping something that interests 
you as you learn. If you want to keep it simple, be my guest. 
 
Options (all data can be found in the /bonusdata folder) 
 

1. Make a county-level map of 2020 US election results, just 
like we did earlier on (but a bit prettier, perhaps) – and 
including city labels, maybe even using a Filter. 

2. Make a UK General Election 2019 map (with place labels). 
3. Make a map of global population change by country, 

between any two dates of your choosing.  
4. Make a house price map of Greater London but only 

showing colour where there are buildings (for this, you’ll 
use the hpssa_ dataset plus the all_buildings_in… file). 

For some of the options above, you could just re-open one of your earlier saved QGIS projects 
(e.g. from when we were doing the US election map). The idea here is to build upon what we’ve 
already done. For number 4 above, the method for the buildings-only map style can be found in 
the slides file in the /bonusdata folder. 
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I’ll get you started with the Print Layout tools, do a bit of a follow 
along, and then you can take it from there. But first, do this: 
 

• Start a new blank QGIS project.  
 

• Open a new Print Layout in QGIS– you can do this via the 
New Print Layout button , via Project > New Print Layout… 
or via CTRL+P (on Windows) and ⌘+P (Mac). 

 
• When prompted, give the new Print Layout a name. I called 

mine US 2020 because I did a US election map. 
 

You’ll then see something that looks like a blank piece of white 
paper on a grey background – as shown below.  

 
Have a close look at it, then on the following page we’ll work 
through it. Everything you add to a Print Layout is called an Item, 
whether it’s a map, a text box, an image or a map legend. You’ll 
get the hang of it pretty quickly – just get stuck in. 
 
The idea behind the Print Layout is that it’s the area of QGIS in 
which you compose your map layout for saving as a file for 
export – e.g. as a pdf, png and so on. 
 
This is the most important button in the Print Layout! 
We’ll do it in a few minutes ourselves, but if you’re new 
to QGIS then this button can be easy to miss. 
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The screenshot above is for reference now and later, but to get 
you up and running the following buttons are most important. 
 

Button What it does – try them all for yourself 

 

This allows you to select different elements in the Print 
Layout and (e.g.) resize, move them around. 

 

With a click and drag, allows you to add your map to the 
Print Layout. You can add multiple maps if you like. 

 

Use this button to add a title and any other text you fancy. 

 

This button allows you to add a Legend to your map – it can 
be a bit fiddly, but have a go and I’ll help you along. 

 

Use this to move the map inside your map frame – and you 
can scroll to zoom in or out here too.  

This is the Item 
Properties tab – 
everything you 

add to the page is 
an Item and can 
be edited here. 
You’ll use this a 

lot. 

To set the Page Properties, including size and 
background colour, right-click and select Page 

Properties… and then edit them in Item Properties. 

The single most important button – this adds 
your map to the page via click-and-drag. 

All Items will appear 
here – use the tick box 

to show/hide. 

Tools to position 
and align Items. 

Zoom to full page 

Refresh page 

Move map within frame 

Select and move an item 

Use these tools to add a legend, text, image, shapes, 
scale bar and north arrow. 
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Follow along demo time 
Okay, time to get our layout as we want it, so try to follow me. 
 
Here are the steps I’ll go through so you can follow. 
 

• I normally set the page size to 320.00mm x 180.00mm because this is 
the correct aspect ratio for full screen viewing (i.e. 16:9). But you can 
choose pre-set page sizes, including A4 and US Letter sizes. 

• Next, I usually add a map – with a simple click and drag. I will often re-
size this to match the page size, but sometimes I leave a white border. 

• Note that when you move Items around a Print Layout they’ll ‘snap’ to 
centre, middle and edges, as well as each other. This is very helpful. 

• Then I’ll edit the map scale via Item Properties on the right.  
• Then I’ll position the map inside the frame using Move item content. 
• Then I’ll add text (title, source, annotations), and re-position/re-size. 
• I often go back to the map data to tweak the symbology as I’m doing 

this, if I’m not happy with anything. 
• Sometimes I use the built-in Legend tool, sometimes I add shapes 

manually, then copy them to create my own legend. 
• I usually only add a north arrow and scale bar if it’s essential. 
• I tend to prefer a subtle off-white colour for the background, with a 

white border to help focus the eye on the main map frame. 
• I use #222222 for dark text rather than #000000 (100% black). 
• If I add an image, I always try to use a svg, they tend to look crisper. 
• I try to achieve visual balance, object alignment and minimal clutter. 
• When I’m happy with it, I go to Layout > Export as image… and then save 

a 300dpi png. Then I inspect the exported map closely and go back and 
fix things I don’t like the look of – often many times. 

• I make sure I save my project here as I go, just in case disaster strikes. 
• I often add some kind of explanatory text and/or annotation to the map, 

and make the title as clear as possible. 
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If you’re used to other GIS software, or none, then the QGIS Print 
Layout can be baffling and/or quirky until you get used to it. I felt 
the same way when I first started using it, but once you get over 
this feeling, you have so much flexibility and freedom to create 
great maps and graphical layouts. 
 
If you remember the basic approach below, you should be ok: 
 
Add an item (map, shape, text box, etc.) to the Print Layout. 
Edit its properties in the Item Properties tab. Refresh Print 
Layout if you change any of the map content. Navigate within 
the map layout using this button . Save project. Export high-
resolution map via Layout > Export as image… 
 
The best way to become proficient with the Print Layout is to 
spend time experimenting with it, and using it for real. 
 
The only other thing to add is that when you add a Legend, by 
default all the layers you have in your map will be in it. This is 
something that’s a lot easier to get used to by trying yourself 
and by following along with me as I show you how. However, I 
often make my legends manually, using just shapes and text. 
 
Top tip 
This  button is how you select/move individual Print Layout items. 
 
Use the little zoom tool in the bottom right of the Print Layout window to 
inspect in detail how your final export will look.   
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9. Exporting maps (two different ways) 
You can export maps from QGIS in two main ways, as below. 
 

1. Export a map from a Print Layout, as we have seen above. 
You can export in lots of different formats, via Layout > 
Export as Image… or by clicking one of these three buttons 

 (the first is for image formats like png, the next 
is for svg and the final one is for pdf exports).  
 

2. You can also export maps directly from the main map view 
in QGIS, using Project > Import/Export > Export Map to 
Image… - this is less flexible but it can also be really useful. 
Also, once you’re in the Export map to Image… options, you 
can choose to Copy to Clipboard and then paste your map 
into another application (e.g. into a ppt slide, or email). 
 

In general, I’d say always use the first option above if you want 
to create the highest quality maps, but if you’re just looking to 
export a map view to provide a general overview, or to show 
someone what you’re working on, the second option is very 
useful.  
 

• From the Print Layout you currently have open, try to export 
your map once each as a png (300dpi), jpg (300dpi), pdf 
and svg – if there’s time for this. Once you’ve done it, 
compare them – e.g. image quality, details and so on. I 
always recommend a 300dpi png when exporting maps.  
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This kind of experimental exporting and comparing of formats is 
not something most people think about doing, but it can be very 
helpful. In general a 300dpi png is preferable over a 300dpi jpg 
because the png is a ‘lossless’ file format and what you see in 
your Print Layout is what you’ll get in the final file, quality-wise.  
 
With jpg, you will often notice a fuzziness, particularly with red 
shades, because it is a ‘lossy’ file format – it gets compressed. 
 

• Now go back to your main QGIS map view, and at this point 
I’d recommend saving your project again – as before, with 
the current page number added to the project file name. 

 
• Before we go to Project > Import/Export > Export map to 

Image… I want you instead to do the following: go to View > 
Decorations and then you’ll see the following options, 
below. 
 

• You can add a variety of different 
Decorations, as QGIS calls them. When you 
go to export images in this way, these 
Decorations will be included in your image 
file, unless you untick the Draw Annotations 
box in the Save Map as Image window. 
 

You’ll find these options simple enough to use, so see if you 
do something like my screenshot below, with Title Label… 
Copyright Label… (in the bottom left) and Image… 
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• Once you’re happy with the way your map looks, go ahead 
and export it as a 300dpi png, or as a pdf. 

 
• If you’ve come this far you’ve done well! Save your project 

once again, take a deep breath, and then go to the next 
page.  
 
 

Baffled? 
Are you baffled, mildly confused, just wondering about something? 
If so, that’s 100% to be expected because there is a lot of material in here – 
so long as you have mastered the fundamentals and know your way round 
QGIS that is great. But feel free to ask me anything now, or later. 

Added via View > 
Decorations > Title Label…  

Added via View > 
Decorations > 

Copyright Labe…l 
Added via View > Decorations > 
Image… You can add any image 

you like here. Anything. 
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10. Putting it all into practice 
If you’ve reached this point before the scheduled end of the 
training session, that’s great – you can now continue and 
perhaps take things a step further (but feel free to chill, go off in 
your own direction, or just ask me anything). If you’re reading 
this at some point beyond the end of the training day, that’s not 
a problem either. The idea behind these sessions is to offer 
structure, but also to allow time for experimentation. 
 
With this in mind, here are some suggestions for ways you can 
put all your QGIS skills into practice, now or in the future. 
 

• Revisit some of the map projects you have saved from the 
different parts of this workbook (e.g. the US county-level 
election data) – you can do this easily because you have 
saved a QGIS project file for different points in the 
workbook. 
 

• Take some time to explore more of the datasets in the 
training data folders – i.e. both the /bonusdata one and 
the /data one. 
 

• Play around with the Print Layout until you’re comfortable 
with how to compose a nice-looking map. 

 
If you have any questions after this session, or you just can’t 
figure something out, feel free to get in touch with me. 
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11. Credits 
 
QGIS - QGIS is a user friendly Open Source Geographic Information System 
(GIS) licensed under the GNU General Public License. QGIS is an official 
project of the Open Source Geospatial Foundation (OSGeo). 
https://www.qgis.org/en/site/about/index.html  
 
Natural Earth – ‘no permission is needed to use Natural Earth data’. All 
versions of Natural Earth raster + vector map data found on this website 
are in the public domain. 
https://www.naturalearthdata.com/about/terms-of-use/ 
 
SimpleMaps – World Cities Database (Basic), used under the Creative 
Commons Attribution 4.0 licence. 
https://simplemaps.com/data/world-cities 
 
World Bank – Population data, used under the Creative Commons 
Attribution 4.0 licence. 
https://data.worldbank.org/indicator/SP.POP.TOTL 
 
US Election data – county-level data, compiled by Tony McGovern 
https://github.com/tonmcg/US_County_Level_Election_Results_08-20 
 
Emojis are from Twemoji, at twemoji.twitter.com, licenced under the CC-BY 
4.0 licence. 
https://twemoji.twitter.com/ 
 
Poppins Font - Designed by Indian Type Foundry, Jonny Pinhorn, licenced 
under the Open Font Licence. 
https://scripts.sil.org/cms/scripts/page.php?site_id=nrsi&id=OFL 
 
 

https://www.qgis.org/en/site/about/index.html
https://creativecommons.org/licenses/by/4.0/
https://creativecommons.org/licenses/by/4.0/
https://creativecommons.org/licenses/by/4.0/
https://creativecommons.org/licenses/by/4.0/
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12. Useful links 
Natural Earth – the best source for easy-to-use global map data, e.g. 
countries, places, states, roads, coastlines and much more. 
https://www.naturalearthdata.com 
 
simplemaps – world cities csv files, with lat/long coordinates. This is a 
great source for place name data. 
https://simplemaps.com/data/world-cities 
 
Sentinel-2 cloudless – for adding satellite imagery to QGIS. Right-click 
WMS/WMTS in the QGIS browser panel, then click New Connection… add 
Sentinel-2 cloudless to the Name and the second url below to the URL field. 
https://s2maps.eu/ 
https://tiles.maps.eox.at/wms?service=wms&request=getcapabilities 
 
OS OpenData Downloads (Ordnance Survey) – a huge amount of free, 
open geospatial data are now available from Ordnance Survey via their 
Open Data Hub. The data covers Great Britain and no registration is 
required. 
https://osdatahub.os.uk/downloads/open 
 
ONS Geography Portal (UK) – see the Boundaries section of this website 
for a wide range of UK boundary data. This site includes data for the whole 
of the UK, whereas Ordnance Survey data only covers Great Britain. A great 
resource. 
https://geoportal.statistics.gov.uk/ 
 
QGIS Documentation – the official docs from the people who make QGIS. 
https://www.qgis.org/en/docs/index.html 
  

https://www.naturalearthdata.com/
https://s2maps.eu/
https://tiles.maps.eox.at/wms?service=wms&request=getcapabilities
https://osdatahub.os.uk/downloads/open
https://www.qgis.org/en/docs/index.html
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Back page cheat sheet 
These are things I use myself – to make things work faster, better, smoother.  
• CTRL+Tab turns panels on/off so the map area is full screen width. 
• Select some features, Edit > Copy Features then Edit > Paste Features As a new 

temporary layer (called a ‘scratch’ layer) or a new vector layer. 
• F11 for full screen mode, F1 for QGIS User Guide, F6 to open Attribute table (on Windows). 
• CTRL+Shift+Tab for full screen map mode (on Windows). Same again to undo. 
• Change projection for project (it doesn’t alter any data) via EPSG button, bottom right. 
• Black is too harsh, try #222222 / RGB 34, 34, 34 instead. Go beyond default colours! 
• Where is your layer stored? Double-click a layer, go to Information and see Path. 
• Turn on the thousand separator (1,000 vs 1000) – Settings > Options > General, tick box. 
• Want to save the position of your map? Use View > New Spatial Bookmark. 
• Print Layout looking fuzzy? Just hit refresh and that will fix it. 
• Print Layout page not zooming to full extent? Re-size your page, then reset to original. 
• Save your most commonly used data source paths as Favorites in the Browser. 
• When styling layers, you don’t have to use only the columns you already have – e.g. 

you can style based on calculations or even by extracting portions of text. 
• Hey, my lovely XYZ base map looks a bit fuzzy! Set projection to EPSG:3857. 
• Hey, my joined layer has weird column header names! Go back into Joins, and edit the 

join so that the Custom Field Name Prefix is ticked and the box is blank. 
• How do you do those glowing lines/polygons? That’s via Blending mode in Symbology. 
• Help! My side panel things have disappeared. Go to View > Panels. 
• Use Inverted polygons with a filter and a satellite base layer to create nice area maps 

– make layer white/black and use about 75% Opacity. 
• Go to Processing > History to view or re-run your recent geoprocessing tasks. 
• A general carto tip: try to make your map as simple as possible, remove any junk. 
• Type world into the Coordinate box if you want a world countries layer to use. 
• Use a 16:9 aspect ratio if your maps are mainly for screens (e.g. 320mm x 180mm). 
• Map a list of x and y coordinates quickly via Delimited Text in Data Source Manager. 
• Drag and drop files from your file browser directly into QGIS (e.g. shp, gpkg etc). 
• You can add layers via the WMS/WMTS option in Browser. Just Google it. 
• Want to save/re-use a map style for a layer? Layer Properties > Style > Save Style…  
• If you give the qml file the same name as a layer file and put it in the same folder as 

the file then when you add it to QGIS that style will be applied by default. 
• Learn about Draw effects! Use them to add a glow or a shadow to features. 
• View > Preview Mode to see your map in colour-blind safe modes or greyscale. 
• Best Plugins? MMQGIS, SRTM Downloader, Build Globe View, Qgis2threejs, qgis2web. 
• Add base maps via XYZ Tiles in Browser panel. OpenStreetMap is there by default. 


